
    Computer Aided Educational Tools

We are all witnessing widespread developments in IT Education. More and more ICTs (Information 
Communication Technology) are  being used in almost all aspects of our lives. In our education 
system all teaching-learning methods are witnessing a shift from teacher centred teaching to a more 
learner centred one. The possibility of making this shift is high by using computer aided tools to 
bring to life abstract mathematics and science concepts. 
National Curriculum Framework (NCF) 2005 talks of a major shift in teaching education 
programme from passive reception to active participation in learning. From learning within the four 
walls of classrooms to learning in the wider social context. From knowledge as “given” and fixed to 
knowledge as it evolves and is created. From linear exposure to multiple and divergent exposure. 
Moving from  a teacher centred lecture driven classroom to more learner centred classrooms. Using 
these computer  aided tools as teaching-learning aids will enable teachers to make these shifts 
suggested by the NCF 2005.   The children will be able to construct their own knowledge  via hands 
on experimentation by using these computer tools. To enable children to connect these learnings and 
utilize the tools to the best possible extent, it is essential for subject teachers to facilitate this 
learning experience.
It is therefore important for the teacher to understand how to use these various tools and become 
confident users of the same to bring about maximum understanding of the subject using these tools 
as aids.
Integrating tool with classroom lessons
There is no one fixed solution that works for integration of computer aided tool usage with 
classroom chalk-talk lessons. It depends on the teacher, her students and the availability of 
computers. If the students have access to the computer in groups in the computer period, then one 
could follow the process outlined below.

 Introduce the topic in the classroom with regular chalk and talk process
 Create an activity related to the topic to be done in the computer period in the lab.
 Discuss the topic and learning in the classroom again after the students  have done the 

activity.
There may not be time available to cover each and every topic in this manner. The teachers must 
use their judgement to plan which topics they think are key or critical to integrate with the tool.  

      List of Tools and their usage

We give here some important tools and a brief description of how to incorporate them into lessons.

 Freemind

About Freemind
Freemind is primarily a tool for creating and editing mind maps. It can be used by teachers to plan 



lessons, plan stories, organize their academic year etc...
Resources of mind maps available for teachers
www.gnowledge.org   has many mind maps created for teaching various topics in many subjects 
that can help you plan lessons and also get new ideas.
How to Install Freemind
Please see section on how to Install New 
Software in this document.
How to use Freemind
To Open from the desktop menu select 
Applications > Office > Freemind
Once Freemind is open for Help select 
menu option Help > Documentation
To create a mind map, first select the mode 
as Modes > Mindmap  (shortcut ALT+1) 
then select FILE > NEW (shortcut 
Ctrl+N). You  should see a screen as 
follows:
To save select menu option FILE > SAVE 
AS  to see the window below, select the 
folder 
/home/bindu/Documents/ITFC/TCoL)  to save file and also the name (story) of the mind map.
Note: [./ - means current folder; .//  - means parent folder]
To start writing the mind map use the following options selecting from the menu option
 Edit >  Edit  (Shortcut F2)
 Edit > Edit a Long Node (Shortcut Alt +Enter)
 Edit >  New Child Node (Shortcut Insert)

 Science

Simulating Experiments using a Computer Tool  
Science is best learnt by doing and observing. When for different reasons the students do not have 
access to physics laboratory, making use of computer aided tools to simulate these phenomenon 
provide students with a virtual laboratory. Using these tools that simulate a science lab is useful to 
bring children closer to visualize the concepts better and therefore understand some of the complex 

http://www.gknowledge.org/


and abstract phenomenon. 
Audio visual aids played an important role to classroom teaching and learning. But in the present 
context of constructivist learning, interactive software becomes very relevant as it enables children 
to construct their own experiments and observe the results.

PhET

How to install PhET

Please see the section Additional Installation Guidelines 

PhET is a tool that has several science 
simulations already built-in.  There  are 
simulations in Physics, Chemistry and 
Biology.  The power of this tool is that it is 
possible to simulate experiments that are 
difficult to perform.  It is also very 
effective for analysing phenomena that 
occur.  This is how the PhET window 
looks.  We will now click on the orange 
tab which says “Play with sims....>”

PhET Opens in the Firefox Web Browser. 
When you install the Ubuntu public 
software, PhET simulations are already 
downloaded on your machine, so you do 
not need internet access. 
How to open a simulation
As an example a simulation in Physics is shown below.  
This will open a page of simulations with an index on the left.  Click on  Physics and Motion under 
Physics on the index.   You will see all the simulations listed here.



Now select  Energy Skate Park . 

This simulation shows total energy is conserved and how Potential Energy-Kinetic Energy 
conversion takes place.
When we click on this simulation the application will prompt you to either Open or Save it locally. 
As all files are already saved locally click on open to start the simulation.  
Lesson plan using a simulation
The simulation window will open which looks like this.

The simulation settings in more detail below.
• There is a track along which the skater can move.
• We can choose the skater; the mass. 
• You can choose to add measuring tapes; this will help measure 

distance.  If you mark the potential  energy reference, you can 
see where the PE is zero.  The grid will help plot the position. 

• You can also choose to see the path – the points will be marked 
on the simulation as the skater goes back and forth. The display 
of KE, PE and total energy can be shown through a bar graph. 
The “pie chart” gives you the legend. 

• You can also plot the energy changes with respect to time as well 
as position of the skater. One key parameter in the simulation is 
gravity. 



• You can simulate this experiment on the moon, Earth or Jupiter.  You can also simulate it in 
space.  The value of “g” in the box will change when you click on these different options. 
Notice that gravity is given as N/Kg; what we refer here is acceleration due to gravity and 
has the units m/s2.  

• We can also add track friction (not visible in this snapshot) and demonstrate what happens to 
the skater.  

Process
• Now  start the simulation; after adding the grid.
• Add add the PE reference at 0 metres to be 0.  
• Now we will click on the Bar Graph:  This will show the changes between PE and KE. 

Notice that the thermal energy is zero.
• Energy Position Graph  Energy-time graph.  This will display the PE and KE with respect to 

position above the ground.
• The Energy Time Graph will show the PE and KE swings across time.
• Notice that in all these graphs the KE reaches zero; but the PE is never zero.  The PE is 

never zero because we the lowest part of the track is still above the ground; we have defined 
the ground as the PE reference of zero. A snapshot of these graphs is given below.

Now we will 
look at what 
happens to 
the skater 
when you add 
track friction 
and we plot 
all these 
graphs.
This is how 
the graph will 
look as the 
skater slows 
down due to 
friction and 
the KE 
reduces to 
zero.

Now the skater has come to rest and the KE has come to zero.  



Now you can reset 
the simulation and 
run it for different 
values of 
acceleration due to 
gravity.

Questions for 
discussion:
What do we mean 
by PE reference?
What does change 
in PE mean with respect to the reference?
What are the implications of adding friction?
Can you connect this to the gravitational force of attraction?

 Step

About  STEP
STEP is an interactive tool for Physics; it can be used for simulating complex interactions in 
mechanics.
Installing Step 
Please see the Install New Software  section to install it if it is not available on your Ubuntu system. 
You will need to be connected to the internet for this.
Opening STEP

On the desktop click Applications > Science > Step  OR    Applications > Education> Step 
The STEP Window
This is how the STEP window looks. The  main components : 



Palette – which contains the objects, interactions and components
World Scene -  where the objects interactions and components are added to create the simulation 
Properties Window – Where properties of objects from the palette can be viewed and edited
History Window – Where the history of the simulation is recorded
Simulate Button – To start and stop a simulation  
Lesson Plan using a simulation
Purpose
Learn to create a simulation in STEP. This activity will simulate free fall of an object.
Process 

• Click on a Disk in the palette window and then click on the world scene to add the object 
• Once an object has been added, an interaction can be added to the object 
• Click on Weight Force  in the palette window and then click on the disk in the world scene . 

A red line will appear indicating that the interaction has been added.
• Now click on Simulate to view the simulation.
• To restore the objects to their original position click on undo 
• Observe  the disk properties in the properties window and discuss 



To save a simulation in STEP   ,   
• go to menu item File -> Save As 
• All files will be saved with the extension “step”. 
• Once you save a simulation, you can simply open a simulation and demonstrate.

   K Tech Lab

About K Tech Lab
K Tech Lab is a free software which helps to make different types of circuits (electronic & 
electrical) and conduct experiments. Various electronic components like resistor, diode, switch, 
transistor, micro controllers etc. can be run using this software. Since it works in GUI mode, it is 
very easy to handle. The components required for electric circuits can be easily dragged into the 
work area using a mouse. When we join the pins using mouse, the circuit is formed. The properties 
of each component is displayed when bring the pointer above it. Students are not  able to do some 
experiments which involve real devices and consumables, even in groups. But these experiments 
can be done in KTech Lab environment. Thus loss due to the damages and lack of consumables can 
be avoided. Using this software students can easily form the circuits and can repeat the experiments 
a number of times. 
How to Install K Tech Lab

• You will require Internet connections

• Go to http://sourceforge.net/projects/ktechlab/

• Click on the green download button and click save.

• The file ktechlab_0.3-6_i386.deb will be downloaded.

• Go to Ubuntu Menu Places > Home Folder

• Select Downloads folder

• Double click on  ktechlab_0.3-6_i386.deb, the software will be installed

http://sourceforge.net/projects/ktechlab/


Introduction to K Tech Lab Interface

First in the File Menu Option Select File > New and Select Circuit as shown below

K Tech Lab Window

Component Tab 
This tab contains different electronic 
components that can be used in K 
Tech Lab. It includes various 

electrical components, discrete components, switches, output devices, logic components, 
connection, Integrated Chips etc. 
Sources : This section contains various voltages, current sources. 
Discrete : Resistors, Condensers, Diodes, transistors etc. are available here. 
Outputs : Output components such as LED, Signal Lamp, devices like Voltmeter, Ammeter, 
Oscilloscope etc. are arranged in this section. 
Work Area: This is the space for building the  electronic circuits. 
Oscilloscope: It helps to recognise the signals with wave form in graphical mode. 
All components can be dragged and dropped in the Work Area  to create a circuit.
To connect the components to make a circuit select either 'Automatic' or 'Manual' as shown below. 
Please use Automatic as a beginner.
Automatic : Select 'Automatic' from the connection routing mode in the toolbar. The pointer 
changes its shape when brought to the lead of the component to be connected. The drag and reach 
near the lead of the other component. The 
colour of the line changes and the 
connection is completed when the mouse is 
released. 
Manual :  Select 'Manual' from the 
connection routing mode in the toolbar. To 
connect the leads of the electronic 
components in this mode, bring the mouse 
pointer near the first lead. The mouse 
pointer changes, then click at the point and 
drag in the direction we require. To have a 
bend 



in the circuit click and move the mouse according to our need. When we reach the next lead the 
colour of the line changes, then click and complete the connection. 
To change the orientation of the electronic components: Right click on the component, which is 
in the work area, and then change the orientation of that electronic component as required. 
Activity 1:  Basic Circuit 
Purpose:  To learn to make a basic circuit with battery, switch,  signal lamp and voltmeter
Process

1. Drag and Drop a a battery, switch 
(SPST) and a signal lamp in the 
work area.

2. Use 'Automatic' connection and the 
mouse to connect the circuits as 
shown below.

3. Click on the switch to see the lamp 
glow.

4. Add  a voltmeter and observe the 
reading when the switch is turned 
off  versus on.

5. Save a K Tech Lab Circuit file

Save File : Select  File > Save and enter 
file name Activity_1 and save the file. It 
will save with a .Circuit extension. Click 
on Save
To open a file select File > Open and 
select file to open
Discussion Points

• Discuss this with reference to a 
torch.

• Discuss what happens when the 
circuit is broken (switch is off), so 
children understand that a switch 
breaks a circuit.

Activity 2:  Cells in Series/Parallel
Purpose:  To connect cells in series and 
observe the voltmeter and ammeter 
readings readings
Process

1. Drag and Drop 3batteries, switch 
(SPST), a signal lamp  and 
voltmeter as shown in the figures 
in the work area.

2. Use 'Automatic' connection and the 
mouse to connect the circuits as 
shown below, first the cells in 
series, then the cells in parallel.

3. Click on the switch to see the lamp 
glow.

4. Observe the reading of the 
voltmeter when the switch is 
turned off/on versus on.

5. Save the file as Activity_2



Discussion Points
• You may discuss what happens to the  current and voltage (potential difference) when 

connected in series .
• Compare water flowing through a pipe, and current flowing through the circuit and see if it 

can be explained this way.
Activity 3 Ohms Law Verification
Purpose
To verify Ohms Law

Process
1. Drag and Drop  a batteries, switch 

(SPST), an ammeter  and voltmeter 
as shown in the figure here.

2. Use 'Automatic' connection and the 
mouse to connect the circuits as 
shown below.

3. Click on the switch and record the 
voltmeter and ammeter readings

4. Click on the resistor and change the 
value of the resistance and record 
the readings of the meters. 

5. Click on the battery and change the 
voltage of the battery.

6. Record the different readings.
7. Save the file as Activity_3

 Social Science

 KGeography

About KGeography
KGeography  is a Geography educational tool that allows you to explore maps by continents, 
countries. Children can explore states, their capitals, flags etc of each country. 
Purpose
In an interactive and fun way allow children to explore the world maps and create activities to 
enhance the children's knowledge about a specific continent, country or state. Can introduce 
children to concept of direction (north south east west), routes etc...
How to Install KGeography
Please see section on how to Install New Software in this document.
Activity 1:  To open and use the basic Explore Map option.

 To access 
KGeography click 
on  Applications 



> Education> Kgeography
• To explore a continent or country click on   File > Open Map and select a country and click 

OK
• Place mouse over the region in 

colour and left-click to view Name 
and Capital

Computer Lab Activity Ideas:
1. First explore India, and all the 

states and capital
2. Point out the islands of India and 

talk about what islands are.
3. Explore North South East West 

directions 
4. Talk about what a capital of the 

state means, also talk about the 
capital of the country.

5. Ask if someone has to travel from 
place A to B (Bangalore, Karnataka to 
Puri, Orrisa) what states they need to pass 
and which direction they need to travel.

6. Identify the smallest and largest states
7. What states are called the “Seven Sisters”. What is Karnataka called ?

Activity 2 : Test yourself
• To test yourself , select any tab (Location of States and Territories)  in Test Yourself as 

seen in image in previous page.
• The window below will appear, select the number of questions (1 to 35) and select OK
• The question will appear on the left hand panel 
• When all questions are completed 

the results are shown below. Each 
state is marked by a distinct colour 
and the result shows the correct 
answer and what the user marked.

 Marble

Marble is like a desktop Atlas that you can 
use to learn more about Earth. You can 
zoom in and out looking at different places 
in the world.  There are different thematic 
map here: A classroom-style topographic 
map, a satellite view, street map, earth at  
night and temperature and precipitation 
maps. All maps include a custom map key, so it can also be used as an educational tool for use in 
class-rooms. For educational purposes you can also change date and time and watch how the starry 
sky and the twilight zone on the map change. Not only do you get globe view, but you can change it 
to a Flat Map as well. 
How to install

• Go to system – Administration – Synaptic Package Manager. 
• Type Marble in the search bar.
• It will usually be the first option that you get. Right-click – Click on Mark for Installation. 
• Click on Apply 
• Once this is complete, Marble will be available in Applications – Education – Marble. 



How to Measure Distances
To measure the distances between two 
places on the earth, right click on the first 
location and click on “add to measure”. 
Click on the second location. 

• A red line is drawn between the two 
locations and the distance can be 
seen on the top left corner in a box. 

• How to Set the time
• You can change the time to 

whatever you like on Marble. Go to 
View – Sun Control 

• Use this window to play around 
with the time 

•

• How to Download new maps 
• Go to file – Download Maps. Click 

“install” on the maps you want to 
download. (you need to be 
connected to the Internet for this). 
For more information on how to 
use Marble, please click 

http://docs.kde.org/development/en/kdeedu/marble/ 

 KStars

About KStars

KStars is a Desktop Planetarium for KDE. It provides an accurate graphical simulation of the night 
sky, from any location on Earth, at any date and time. The display includes upto 100 million stars, 
13,000 deep-sky objects,all 8 planets, the Sun and Moon, and thousands of comets and asteroids.
To access KStars click on  Applications > Science> Kstars
Activity 1 Solar Eclipse 
Purpose 
To view the solar eclipse as seen in 
Bangalore on January 15th 2010.
Process

1. Set the location as Bangalore by 
selecting file menu option Settings 
> Geographic or pressing Ctrl+G

2. Select Bangalore, India as the 
location.

http://docs.kde.org/development/en/kdeedu/marble/


3. Set the time by selecting file menu 
option Time > Set Time or pressing 
Ctrl+S

4. 4. Press Ctrl+F and 
find the sun on the map.

5. Press the play/Pause button to start the 
simulation, and keep the time at 
10seconds

Activity 2 Solar System 
Purpose
View the solar system. And 
see the revolution of the 
planets around the sun.

Process
1. Set the location as Bangalore by selecting file menu option Tools > Solar System or 

pressing Ctrl+Y
2. Press Play button to simulate the movements of the planets
3. Use the scale to place an orbit of any planet at 0 , when the planet is at position 0, note the 

clock measure  and stop the clock when it comes back to zero position to measure how long 
the planet takes to complete one revolution.



Mathematics

Geogebra

Introduction to Drawing in Geometry
In many of our schools we are seeing children struggling to grasp mathematics concepts. 
Sometimes explaining concepts such as point, line, plane, chord, radius become very vague for 
children and hence prevents them from grasping the concepts completely and hence they struggle to 
progress in the subject. 
There are many new methods that are being adopted to make concepts less abstract in mathematics 
like using pictures, cutting shapes out of cardboard etc... Often these aids are very time consuming. 
IT based tools allow us to easily manipulate drawings and allow children hands-on experience and 
visual stimulation to make mathematics come alive and be less vague.
Geogebra is a good example of a computer aided tool, which helps us in learning Geometry, 
Algebra and Calculus. It is a free software, which functions in GNU Linux Operating System.
Geogebra  cannot replace children using the compass box to draw. The children in classes must  use 
the compass box and pencils to draw and construct. This tool must be used by teachers to animate 
some concepts and theorems to enable them to use it as a teaching aid to further their own teaching 
methodologies.
About Geogebra 
Geogebra is dynamic mathematics computer aided tool  for schools that combines geometry, 
algebra, and calculus.
One part of  Geogebra is an interactive geometry system. You can do constructions with points, line 
segments, parallel lines, line intersections, polygons, circles and more. 
Another part of Geogebra allows you to enter  equations and coordinates directly. Thus, Geogebra 
has the ability to deal with variables for numbers, vectors, and points. 
You can also see the algebraic expressions of the figures you draw and change the values in 
algebraic expressions to dynamically see the change in the geometry figure and vice-versa.
Opening Geogebra
On the desktop click Applications > 
Science > Geogebra or Applications > 
Education> Geogebra.
Installing Geogebra
Please see the Install New Software 
section to install it if it is not available on 
your Ubuntu system. You will need to be 
connected to the internet for this.
The Geogebra Window



The figure shows the default Geogebra Window.  The details of each section are explained below.
Menu Bar: Typical windows command menu bar. We will be using the File command only.  
Tool Bar:  Has all the tools (compass box) to use in the graphic view 
Display for Tools: It tells you which tool is active to use on the graphic view
Graphic  View:  Used to draw the geometric figures. This window can never be closed.
Algebra  View: Shows the algebraic expressions. This window can be closed if you are working 
only on geometry.
Input Bar: This is used to enter more complex mathematical expressions that may not be available 
on the Tool Bar. (Not used in this training session)
Commands: To use along with the  Input Bar, to select from a list of available commands. (Not 
used in this training session)
Tool Bar
We can  consider the Tool Bar to be like a compass box. Today we will consider the Geogebra tools 

that correspond to  using a pencil, a ruler and a compass in a compass box.
To see the list of related tools , click on the 
arrow at the bottom right hand corner of 
each tool as shown below. 
Basic Use of Tools (Refer to above 
diagram, left)

• Activate a tool by clicking on the 
button showing the corresponding 
icon. 

• Open a toolbox by clicking on the 
lower part of a button and select 
another tool from this toolbox. 

Graphic Window with Grids Displayed 
(Refer to above diagram,right)

• Place the mouse pointer over the 
graphic view area. Right Click and 
check the Grid option. To remove 
the grid view, un-check the option. 
See diagram below.

Activity 1:  Drawing pictures with Geogebra 
Purpose: To familiarize oneself with the Geogebra window and some of the basic geometry tools.
Process
Use the mouse and the following selection of tools in order to draw figures on the drawing pad.
Start by drawing the following : [ A Point,  A Line Segment,  A Square, A House, A Circle]



Hint Box

• Observe the Algebra View
• Geogebra is case sensitive and uses mathematical naming norms
• If you move the cursor close to the grid intersection, it will show you the point 

of the intersection and you can click to place the object at the intersection 
coordinates

• Use the move icon to move the figure you have drawn and observe the algebra 
window

• You can also move the labels to make the diagram more readable
Activity 2 : Saving/Opening Geogebra files 
Purpose
Save and retrieve Geogebra Files.
Process

1. Open the File menu (Menu Bar) and select Save. 
2. Select the folder Your Name > 

Workshop >  Geogebra  in the 
pop-up  dialogue window. 

3. Type in a name for your 
Geogebra file. 

4. Click the Save  button to save 
the file. 

To Open an existing Geogebra file 
select menu File > Open. A Open 
Window (just like the save window) 
pops up. Select the folder that you had 
saved the file and look for the file with 
extension '.ggb' in the box on the left 
side and click Open.

Hint Box

• A file with the extension ‘.ggb’ is created. This file extension can only be 



opened with Geogebra. 
• Give simple short names for your files like Activity_1.ggb.

Activity 3 (Measurement)
Purpose
To learn to use the measurement tools 
Angle  and Distance and Length.
Process

1. Open file 'Activity_1.ggb'.
2. To measure select the tools from 

the Angle toolbar. Use these tools 
to measure the following
i. Measure the Length of the 

Line Segment (Distance or 
Length)

ii. Measure the Angles of the 
Square (Angle)

iii. Measure the Circumference of 
the circle (Distance or 
Length)

Hint Box

• When you select an object on the graphics window, it gets highlighted.
• You can right click on any object, select properties and can change properties such 

as colour, what to display : Name, Value etc... (See Diagram Below)
• To measure interior angles, the three points must be selected clock-wise , so the 

middle point selected is where the angle is measured.
Activity 4  Triangles 
Purpose 
To verify that the sum of the interior angles of a triangle are 180 degrees. 
Process

1. Draw three points A, B, C (New Point tool)
2. Draw three line segments  AB, AC, BC (Segment between two points tool)
3. Select the Angle tool to measure each of the interior angles of the triangle.
4. Now verify that the sum of all the interior angles equals to 180 degrees.
5. Select one of the vertices of the triangle (A,B or C) and move the points (Move tool) to 

change the shape of the triangles. 



Hint Box

• Remember to save the file as 'Activity_4.ggb'
• Notice which objects are free objects and which objects are dependent objects. 

You can move only free objects

Constructive Corner

• You may make the children do this exercise before you prove the theorem in 
class, allowing the children to arrive at the theorem themselves. 

• Observe what happens when you move all three points A,B,C to lie on a 
straight line.

• Creating tables like the one below and asking them to write down the values, 
would help them focus on what to observe.

Angle BAC Angle CBA Angle ACB Sum of all Angles

Activity 5 (Explain different types of polygons)
Purpose
To demonstrate the different types of polygons .
Process

1. Create a slider by clicking on the Slider tool

2. Select Radio Button: Number, 
Name: a, 
min: 3, 
max:10, 
Increment: 1 and press Apply.



3. Select the tool Regular Polygon and mark the two points A and B of one side of the 
polygon on the drawing pad. You will be prompted with a window as shown. Please put the 
slider name “a” in the box provided and press OK.

4. Select  the Insert Text tool and write the text: 
A polygon with three sides is called a 
TRAINGLE    as shown in the figure along-
side and press OK.

5. Right click on the text created and select 
object properties. Click the Advanced tab. 
Enter a=3 in Condition to Show Object 
and press OK.

6. Repeat steps 4 and 5 for as many polygons 
7 more times to show up to 10 sided 
polygon.

7. Select the move tool and demonstrate the 
different polygons.

Constructive Corner

• What is the minimum number of points you need to define to make a 
polygon.

• What is a regular polygon (All Sides are equal)
• Ask the students to try and recognise more properties in each 



polygon.
Activity 6 (Explain different terms related to circle)
Purpose
To enable understanding of different terms and definitions related to a circle.
Circle: The collection of all the points in a plane, which are at a fixed distance from a fixed point in 
the plane, is called a circle. The fixed point is called the centre of the circle and the fixed distance is 
called the radius of the circle.
Process     

1. Draw a Circle  using the circle with centre through point tool
2. Draw multiple line segments using the line Segment tool where one point is on the circle 

centre  and the other point anywhere on the circumference of the circle.
3. Observe the value of the line segments. 

A circle divides the plane on which it lies into three parts. They are: (i) inside the circle, which is 
also called the interior of the circle; (ii) the circle and (iii) outside the circle, which is also called 
the exterior of the circle. The circle and its interior make up the circular region. 
Process

1. Draw a Circle  using the circle with centre through point tool.
2. Select the circle, right click and select object properties.
3. Select the colour tab in the object properties window and choose a colour
4. Select the style tab in the object properties window and change the line thickness and filling 

values.
5. Then explain the three parts described above.

Chord: If you take two points P and Q on a circle, then the line segment PQ is called a chord of the 
circle.  The chord, which passes through the centre of the circle, is called a diameter of the circle. A 
diameter is the longest chord and all diameters have the same length, which is equal to two 
times that of the radius .
Process

1. Draw a circle  using the circle with centre through point tool.
2. Draw many chords for the circle using the line segment tool that do not pass through the 

centre of the circle.
3. Draw multiple chords of the circle using the line segment tool that  pass through the centre 

of the circle (Diameter).
4. Draw a line segment that represents the radius of the circle. 
5. Then explain the three parts described above.

 KTurtle

About Kturtle
Kturtle is a tool to understand basic concepts of programming in computers. The commands are 
simple and can be visualized by children and hence understood easily. It can be seen as giving 
instructions to a robot (the turtle) and making the turtle “do what you want it to do”.



Purpose:
Introduce children to the basic idea of programming and the generic logic constructs. Can make the 
concept of computer programming less intimidating for both teacher and student. In today's digital 
world, mathematics education may be seen  as may areas of learning coming together. These parts 
are conceptual understanding of the mathematics , using the algorithms to internalize and apply the 
conceptual understanding pattern recognition and  logical reasoning especially to understand 
theorems and proofs. K Turtle helps teachers build logical reasoning and pattern recognition  with 
children. As it is visual, many geometric properties can also be understood through the use of K 
Turtle, like making the turtle draw a square requires the child to understand the properties of a 
square. Thus it is very useful to teach logical reasoning side by side with mathematics. This tool 
provides a interactive and easy method to do the same with children starting in the upper primary 
classes. 
Activity 1
Open application Applications > 
Education > Kturtle and introduce the 
user to the following windows, editor and 
canvas.
Editor : Space for entering the commands, 
please note the different colours that are 
used for keywords (blue) and the quantities 
(red) etc...
Canvas: Is see the turtle in action when the 
command being executed.
Now introduce four simple commands 
reset ,forward, backward, turnleft, 
turnright
Reset :Clears the canvas and the turtle is 
positioned in the center of the canvas 
facing forward.
Forward <Number of pixels) : Turtle moves forward by the number of pixels specified
Backward <Number of pixels) : Turtle moves backward by the number of pixels specified
turnleft <Number of Degrees>: Turtle turns left (anti clockwise) by the number of degrees 
specified 
turnright <Number of Degrees>: Turtle turns right (clockwise) by the number of degrees 
specified
Note:  You can also go to menu option  Tools > Direction Chooser.
Type the following commands in the Editor window: 
Reset
forward 100 
turnright 90
backward 100
turnleft 90
forward 50
Do the following:

1. Click Save As  Save the 

File as first

2. Click on Run , try all the 
options full speed, slow, slower, 



slowest and step by step.

Activity 2 : Using the commands from activity 1 create a Square 
Reset
Forward 100
Turnright 90
Forward 100
Turnright 90
Forward 100
Turnright 90
Forward 100
Turnright 90
Investigation
Talk about repeated commands and what they think should be done and lead them to the command 
Repeat <No of Times > { <List of Commands}
Redo Square program as

Reset
Repeat 4 {
      forward 100
      turnright 90
}

Activity 3 :  Using the commands from activity 1 & 2 discuss how a CIRCLE may be created. 
Investigation: 

1. What is the definition of a circle really.
2. What is the relationship between the number of times the command is repeated and the 

command that is within the repeat loop.
3. Can we change the numbers, what happens 

Reset
Repeat  36 {
      forward 10
      turnright 10
}

Table 1: Circle Program

Activity 4  Bringing some colour to the canvas.
Introduce the following commands , can also go to menu Tools > Color Picker  for selecting colour



canvascolor <Amount of Red>, <Amount of Green>, <Amount of Blue> : Changes the colour 
of the canvas
pencolor <Amount of Red>, <Amount of Green>, <Amount of Blue> : Changes the colour of 
the pen   (pencolor 0,0,0 is black) 
penwidth  <thickness of the pen)
Investigation
Learn the concepts of colour mixing with the primary colours red, green and blue
Activity 5 : 
Create a flower or some Rangoli Pattern  as shown below  or any other pattern they come up with
 

reset
canvascolor 255, 115, 119 
pencolor 0,0,0
penwidth 3
repeat 4 {
        turnright 45
        forward 200
        turnright 45
        backward 100
}

reset
canvascolor 255, 115, 119 
pencolor 0,0,0
penwidth 3
repeat 12 {
     repeat 36 {
         forward 10
         turnright 10
     }
    turnright 30
}
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